Skip to main content

 

 

Coupa Success Portal

Important Browser Support Info

Overview

As noted in Release 17 Supported Browsers, Coupa will continue to support Internet Explorer 9 and 10 for R17. However, we'll soon be discontinuing support for these older browsers, and we recommend that you upgrade to Internet Explorer 11. 

If you plan on using IE9 or 10 with any Coupa version, you'll need to configure them to support TLS 1.1 and 1.2 when we disable support for TLS 1.0 on December 16, 2016 for test environments, and March 4, 2017 for production instances.

We ended support for TLS 1.0 as of March 4, 2017. and support for IE9 and IE10 starting with Coupa 18. See Coupa TLS 1.0 Encryption End of Support and End of Support for IE9 and IE10 for more info. 

Configuring TLS

  • Was this article helpful?